Friday, 18 March 2016

JAX-RS 2.0 on Weblogic 12.1.3

JAX-RS 2.0 will not work on Weblogic 12.1.3. The default is 1.0 based on Jersey implementation.

I will post shortly the jars necessary to make it working. Some of the jars were modified by me.


Wednesday, 16 March 2016

JAX-RS 1.0 on Weblogic 12.1.3

Mind you that on Weblogic 12.1.3 only JAX-RS 1.0 will work. The implemention is 1.18.

To enable it, make sure to include in your web-app, the following weblogic.xml :

       

<?xml version="1.0" encoding="UTF-8"?>
<weblogic-web-app xmlns="http://xmlns.oracle.com/weblogic/weblogic-web-app" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd http://xmlns.oracle.com/weblogic/weblogic-web-app http://xmlns.oracle.com/weblogic/weblogic-web-app/1.0/weblogic-web-app.xsd">
  
  <context-root>/webcontext</context-root>
<container-descriptor>
<prefer-web-inf-classes>true
</container-descriptor>
      </weblogic-web-app>

If you deploy the application as an EAR, it is important to note that if you intend to package your applicaton as an EAR, you can only include one WAR, that is only one Jersey web-app will work, multiple ones will fail.

About Me

My Photo